Posts Tagged ‘PowerPC’

Airport Extreme Frustrations

Wouldn’t you know it, I make a glowing post about Apple computers and that very day I experience extreme frustration with our new Airport Extreme N Base Station. Don’t get me wrong, I think the Airport Extreme is a great router for most people (and was packaged just as well as the Mini), but Apple should have acknowledged that it doesn’t work with all older Macs.

I still love the Mini, but am currently frustrated with Apple for poor support for their old computers. I don’t expect them to continue to support old hardware forever, but they should acknowledge what no longer works. Unfortunately, running the Airport with my Powerbook using Mac OS 10.4.11 causes the Powerbook to crash constantly. I called tech support, and they are aware of the issue, but no fix is in sight (I’d seen support posts back as far as last December about this problem, but no notice of it on the Airport’s product page, which indicates any Mac with Airport is compatible, though they list OS versions for several other features, such as 10.2.7 for shared printing and 10.4.8 for sharing a hard drive — we meet those requirements, but nothing is said about 10.4.11 on PowerPC computers crashing with the wireless N router). At the moment, it’s working without the N enabled, but that defeats the purpose of buying a router that will last when we upgrade our hardware. I can buy a Wireless G router for fraction of the cost of the Airport (which I bought refurbished).

I could upgrade my system to 10.5 to solve the problem, but that would cost me as much as or more than the router cost, and I’ve considered upgrading in the past and haven’t felt it was worth it, in part because iMovie 09 won’t run on my old PowerPC computer. I can’t upgrade to 10.6 (the current OS) because you need 10.5 to do so and you can’t install it on PowerPC computers either. Apple switched to Intel processors a few years ago, and they have basically abandoned their old computers.

To be fair, Macs last longer and work better than most PCs I’ve worked with. Apple has done as well as most computer companies to make sure their products are backwards compatible, but the Airport is a noteworthy exception. I’m not even that upset that the router doesn’t work with all old computers — that would be too much to expect, I suppose — but Apple should acknowledge this on their product page under the System Requirements as soon as the issue was confirmed (at least 8 months ago). If you can’t support old hardware, at least let consumers know what is and isn’t supported so we can make an informed decision. Now I am faced with the decision of whether to upgrade or to return the router and buy a cheaper alternative.

I will say that Apple’s Support team has been pretty good with this, though the first person I spoke with wasn’t familiar with the issue. She did get me to try a work around that didn’t work, and they did offer to sell me the upgrade, which you can’t find on the Apple Store by yourself. I will post an update on what my final decision is.

I am also impressed with the Mac community. I figured out what was causing my crashes (Apple calls them kernel panics — and they do cause panic, esp. when they’re so uncommon on a Mac) thanks to the blog Shaniac-iMac, which led me to Apple’s support discussions of the issues. I’ve always loved the free email Mac newsletter Tidbits and I’ve gotten lots of help on using and maintaining older Macs from Low End Mac and iFixIt, which helped me to upgrade two hard drives that were dying on my Powerbook and Kim’s iBook last year. I only wish that Apple would acknowledge that users expect their computers to last longer than a few years and continue to support older models longer. There’s no need to throw away an old computer that still works, but it’s frustrating when new hardware causes the old hardware to stop working.